WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#30643 closed defect (bug) (invalid)

In admin panel author cannot see "Pages" menu item and cannot access any written pages.

Reported by: TomasM Owned by:
Milestone: Priority: normal
Severity: major Version: 4.1
Component: Posts, Post Types Keywords:
Focuses: administration Cc:
PR Number:

Description

I always work as admin, so only recently noticed that if I login as an author, I cannot see the menu "Pages", although I have several pages created under that author.

If I would try to use direct link:

http://site.com/wp-admin/edit.php?post_type=page

I get error:

"Cheatin’ uh?"

Using: WordPress 4.1-beta2-30793

Change History (3)

#1 @TomasM
5 years ago

  • Severity changed from normal to major

#2 @knutsp
5 years ago

  • Keywords close added

Authors doesn't have the "edit_pages" capability by default. This by design.

You may upgrade your authors to editors, or add "edit_pages" to the capabilities of Author on your site. For this you will probably need a plugin.

Last edited 5 years ago by knutsp (previous) (diff)

#3 @SergeyBiryukov
5 years ago

  • Component changed from Administration to Posts, Post Types
  • Focuses administration added
  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

As noted above, the Author role does not have edit_pages capability by default.

Note: See TracTickets for help on using tickets.