WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#30663 closed defect (bug) (duplicate)

fix theme file names

Reported by: kidsguide Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Themes Keywords: theme-editor
Focuses: administration Cc:

Description

If theme subfolders contains any index.php, page.php or something like these, wp-admin diplays those files with the wrong title.

Attachments (3)

file.php (45.9 KB) - added by kidsguide 3 years ago.
file.php.patch (520 bytes) - added by kidsguide 3 years ago.
30663.png (4.1 KB) - added by SergeyBiryukov 3 years ago.
Screenshot of the issue

Download all attachments as: .zip

Change History (11)

@kidsguide
3 years ago

#1 @kidsguide
3 years ago

  • Keywords has-patch 2nd-opinion needs-testing added

#2 @kidsguide
3 years ago

  • Component changed from General to Editor

#3 @SergeyBiryukov
3 years ago

  • Component changed from Editor to Themes
  • Focuses administration added

Could you please attach an SVN patch rather than a PHP file?

See http://make.wordpress.org/core/handbook/submitting-a-patch/.

#4 @kidsguide
3 years ago

I will do that in a second. Sorry about that.

@kidsguide
3 years ago

#5 @obenland
3 years ago

  • Keywords 2nd-opinion removed

Sergey, do you want to do this?

It's marginal, so it would be nice to make a decision either way.

#6 @obenland
3 years ago

  • Keywords theme-editor added

@SergeyBiryukov
3 years ago

Screenshot of the issue

#7 @SergeyBiryukov
3 years ago

  • Keywords needs-patch added; has-patch needs-testing removed

file.php.patch wouldn't work for child themes or any theme other than the current.

#8 @SergeyBiryukov
3 years ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #17036.

Note: See TracTickets for help on using tickets.