WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#30672 closed defect (bug) (fixed)

Default state of the revision screen is incorrectly set at comparing-two-revisions

Reported by: Clorith Owned by: johnbillion
Milestone: 4.1 Priority: normal
Severity: normal Version: 4.1
Component: Revisions Keywords: has-patch commit
Focuses: javascript Cc:

Description

The default state of the revisions class is comparing-two-revisions while the compare checkbox is still unchecked.

This hides the previous/next buttons until the checkbox is ticked and unticked again.

As reported by @ahortin on https://wordpress.org/support/topic/nextprevious-buttons-not-appearing-on-revisions-screen

Attachments (1)

30672.patch (501 bytes) - added by ocean90 6 years ago.

Download all attachments as: .zip

Change History (9)

This ticket was mentioned in Slack in #core by clorith. View the logs.


6 years ago

#2 @ocean90
6 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.1

Confirmed, looking into it now.

Introduced in [30131], #30219.

Last edited 6 years ago by ocean90 (previous) (diff)

@ocean90
6 years ago

#3 follow-up: @ocean90
6 years ago

  • Focuses javascript added; ui removed
  • Keywords has-patch commit added; needs-patch removed

30672.patch will fix the issue. Looks like a copy&paste issue, since there is no need to search for compareTwoMode in the revisions…

#4 @adamsilverstein
6 years ago

looks reasonable, will test.

#5 in reply to: ↑ 3 @adamsilverstein
6 years ago

Replying to ocean90:

30672.patch will fix the issue. Looks like a copy&paste issue, since there is no need to search for compareTwoMode in the revisions…

verified this fixes the issue with the compare any two revisions checkbox and state.

#6 @markjaquith
6 years ago

Looks good, fixes issue.

#7 @ocean90
6 years ago

In 30831:

Revisions: Fix initial state of compareTwoMode.

Broken since [30131].

fixes #30672.

#8 @johnbillion
6 years ago

  • Owner set to johnbillion
  • Resolution set to fixed
  • Status changed from new to closed

In 30851:

Revisions: Fix initial state of compareTwoMode.

Merges [30831] to the 4.1 branch.

Fixes #30672.

Note: See TracTickets for help on using tickets.