WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#30674 closed defect (bug) (fixed)

Twenty Fifteen: Child menu items aren't reachable in some cases.

Reported by: iamtakashi Owned by: lancewillett
Milestone: 4.1 Priority: normal
Severity: normal Version: 4.1
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

When a page is like this: (The sidebar is shorter than viewport and fixed, and the main content is also shorter than the viewport)

https://cldup.com/HP6G40vprI.png

If you have a lot child menu items and if you expand the menu to display them:

https://cldup.com/WC57GAENFy.png

There is no way to reach child menu items at the bottom.

Attachments (1)

30674.diff (2.7 KB) - added by iamtakashi 6 years ago.

Download all attachments as: .zip

Change History (6)

#1 follow-up: @obenland
6 years ago

I can't reproduce. In my tests it's scrollable and I can scroll down to those items.

#2 in reply to: ↑ 1 @iamtakashi
6 years ago

Replying to obenland:

I can't reproduce. In my tests it's scrollable and I can scroll down to those items.

That's weird. It's happening to me on both Chrome and Firefox on Mac.

What inline style do you have on .sidebar initially? It should be position: fixed.

And then when you expand the menu and the sidebar length exceeds your browser window, does the style change?

@iamtakashi
6 years ago

#3 @iamtakashi
6 years ago

  • Keywords has-patch added; needs-patch removed

Anyway, I tweaked a little the conditions in the scroll function and it seems to work well as far as I tested.

#4 @lancewillett
6 years ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 30838:

Twenty Fifteen: update scroll functionality to make sure child menu items are always reachable.

Props iamtakashi, fixes #30674.

#5 @SergeyBiryukov
6 years ago

In 30938:

Twenty Fifteen: update scroll functionality to make sure child menu items are always reachable.

Merges [30838] to the 4.1 branch.

props iamtakashi.
see #30674.

Note: See TracTickets for help on using tickets.