WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#30708 closed defect (bug) (invalid)

Media cannot be inserted as a gallery after a page break in post

Reported by: techtangerine Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Gallery Keywords:
Focuses: Cc:

Description

Normally, I can insert multiple image files as a gallery into a post using Insert Media>Create Gallery>Insert into Post. I also have the Jetpack plugin enabled, and I can also insert the special galleries such as the Tiled Mosaic one, which is only available for jetpack users.

But I have discovered that if I insert a page-break into a post using the tag <!--nextpage-->, and then I try to insert multiple images as an ordinary gallery or as a Jetpack enhanced gallery, the following happens:

All the images used in the post, including those beyond the page-break show up as a basic thumbnail gallery.

There is no way to get past this other than not using galleries to display images.

Change History (5)

#1 @techtangerine
6 years ago

  • Version changed from 4.0 to trunk

Please note that I am using a Caching plugin (QuickCache).

Please also note that my images are hosted using Wordpress's CDN (Photon plugin via Jetpack).

Last edited 6 years ago by techtangerine (previous) (diff)

#2 @iseulde
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version trunk deleted

Hi,

Could you please try this again with all plugins disabled? If it still doesn't work, please reopen this ticket and give us steps to reproduce the issue, otherwise you should report this on the relevant plugin forum.
It works for me in trunk.

#3 @techtangerine
6 years ago

Hi, since the gallery function is a wordpress "plugin," can you please tell me where its plugin forum will be?

#5 @techtangerine
6 years ago

johnbillion, thanks for the link. But I am afraid that's not the right one.

This issue occurs regardless if jetpack is used or not, from what I can see.

This pertains to the "gallery" function that is built into wordpess itself as a feature. It is not a plugin.

Note: See TracTickets for help on using tickets.