WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#30712 closed enhancement (duplicate)

WordPress Multisite -> subfolder installation -> remove /blog slug from root blog.

Reported by: karincom Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0.1
Component: Networks and Sites Keywords:
Focuses: multisite Cc:
PR Number:

Description

Thank you indeed for the work you are doing.
Being unable to find a way to replace the '/blog' slug in root domain, I am using a cron job to update the rewrite rules as work around ('/blog' to '/en').

SQL QUERIES

UPDATE bb_options
SET option_value=replace(option_value,'blog/','en/')
WHERE option_name = 'permalink_structure';

UPDATE bb_options
SET option_value=replace(option_value,'blog/','en/')
WHERE option_name = 'category_base';

UPDATE bb_options
SET option_value=replace(option_value,'blog/','en/')
WHERE option_name = 'rewrite_rules';

It is working beutifully in my site.

So, '/blog' slug is hardcoded for the root blog.
But... it is very easy to change, so, it should be easy to create such parameter.

REQUEST
Why not include such parameter in wp-config.php? At least for subfolders installation.

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from ENHANMENT: Wordpress Multisite -> subfolder installation -> remove /blog slug from root blog. to WordPress Multisite -> subfolder installation -> remove /blog slug from root blog.

Duplicate of #12002 and #17811.

Note: See TracTickets for help on using tickets.