WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#30721 closed defect (bug) (duplicate)

Categories not displaying correctly while posting

Reported by: Xtr3m3X Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0.1
Component: Taxonomy Keywords:
Focuses: ui, administration Cc:
PR Number:

Description

Hello,

I am seeing an issue with my site where the categories/subcategories tree isn't displaying correctly when editing a post. The categories are displaying and are setup correctly when viewing Posts > Categories. When editing a post, subcategories show up as main categories, rather than subcategories. This creates a big mess when working with many levels of subcategories.

I have submitted a ticket to my host (WPEngine) about this problem. After further testing by their support engineers, they came to the conclusion that it is a WP bug. They found out that when the count row in the wp_term_taxonomy table is set to a 0 value, categories do not show up ordered correctly within the post. However, if the value is anything but 0, it will show in all posts, be it that they exist or are newly created.

Please advise on this issue.

Thank you

Attachments (3)

post_cats_1.png (9.3 KB) - added by Xtr3m3X 5 years ago.
post_cats_2.png (9.4 KB) - added by Xtr3m3X 5 years ago.
all_cats.png (17.0 KB) - added by Xtr3m3X 5 years ago.

Download all attachments as: .zip

Change History (6)

@Xtr3m3X
5 years ago

@Xtr3m3X
5 years ago

@Xtr3m3X
5 years ago

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #10982, #14723, #14916, #16475, #17135, #17317, #17835, #19880, #20160, #21544, #21127, #29871.

This is intentional, see #10982. A filter was introduced in #20054, allowing plugins to change that behaviour.

This plugin implements the change: https://wordpress.org/plugins/category-checklist-tree/.

#2 @SergeyBiryukov
5 years ago

  • Component changed from General to Taxonomy
  • Focuses ui administration added

#3 @Xtr3m3X
5 years ago

Thank you. The plugin works perfectly.

Note: See TracTickets for help on using tickets.