Make WordPress Core

Opened 10 years ago

Closed 7 years ago

#30757 closed defect (bug) (worksforme)

Changes to color controls are reverted when customize-loader.js is used

Reported by: celloexpressions's profile celloexpressions Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Customize Keywords: needs-patch
Focuses: Cc:

Description

Despite the high likelihood that this is a 4.1 regression, I've confirmed it in 4.0.

Steps to reproduce:

  1. From the themes screen, with Twenty Fifteen active (though it's not Twenty Fifteen-specific), open the Customizer with the "Customize" button on the active theme.
  2. Change the background color (or any color), note that it updates in the preview, then save and publish. Close the Customizer. Optionally verify that the new color is live on the frontend in a new tab.
  3. Reopen the Customizer from the Customize button on the themes page. Make sure there was no page load in between closing and reopening the Customizer.
  4. As soon as the Customizer loads, the previous color is applied in the controls, and subsequently in the preview.

Note that this particular Customize button, along with a few others, loads the Customizer in a full-screen iframe, so the issues are likely related to customize-loader.js.

Change History (7)

This ticket was mentioned in Slack in #core-customize by celloexpressions. View the logs.


9 years ago

#2 @valendesigns
9 years ago

  • Keywords reporter-feedback added

I cannot reproduce this behavior in Trunk with any theme. Could you check that it's still an issue for you?

#3 @polevaultweb
9 years ago

  • Keywords reporter-feedback removed

@valendesigns I can confirm this is still an issue - https://www.dropbox.com/s/7swdsg5dn0pjex3/customizer_color_issue.mov?dl=0

#4 @valendesigns
9 years ago

Thanks for the video, I can reproduce the issue now. I'm not sure why we're loading the customizer in an iframe in the first place. It seems like we should stop doing that and load it normally.

#5 @dingo_bastard
8 years ago

Tested this on my VVV installation in trunk and in stable build on Twenty Fourteen, Fifeteen and Seventeen and couldn't reproduce it. Has this been solved?

This ticket was mentioned in Slack in #core-customize by melchoyce. View the logs.


7 years ago

#7 @melchoyce
7 years ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Looks like this was fixed some time in the last year. I can't reproduce either. :)

Note: See TracTickets for help on using tickets.