Make WordPress Core

Opened 9 years ago

Closed 17 months ago

#30761 closed defect (bug) (duplicate)

Label of button should read scheduled on quick edit posts when future date set

Reported by: thecellarroom's profile TheCellarRoom Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Quick/Bulk Edit Keywords: has-patch needs-refresh
Focuses: accessibility, administration Cc:

Description

quick edit a draft post and set the date to any future time, the button says 'publish' rather than 'schedule' as it does on the main edit post page.

possibly related to : #19907 #8529

Attachments (1)

30761.1.patch (3.5 KB) - added by GunGeekATX 9 years ago.
Proposed patch

Download all attachments as: .zip

Change History (8)

#1 @TheCellarRoom
9 years ago

clarity: it's the 'publish' in the drop down box for status that should read scheduled the button says 'update' all the time.

#2 @nacin
9 years ago

  • Component changed from Administration to Quick/Bulk Edit
  • Focuses administration added
  • Keywords needs-patch added
  • Version changed from 4.1 to 2.7

Makes sense to me.

#3 @GunGeekATX
9 years ago

  • Keywords has-patch added; needs-patch removed

Proposed patch updates the following:

  1. inline-edit-post.js: new updateText function (copied and modified from the one in post.js), updates the drop down item to either Scheduled or Published
  2. class-wp-posts-list-table.php: has a new hidden div storing the current date and time, used by the inline-edit-post.js updates
  3. script-loader.php: added 'published' and 'scheduled' to the localized inlineEditL10n object.

While working on this, I noticed that when quick editing a scheduled post and setting the date to something earlier than the current date/time, the drop down still says Scheduled until you click Update, even though the post gets published. We could offer a little better visual indication that the post will be published if we change the drop down to say Published when the time is changed before clicking Update.

@GunGeekATX
9 years ago

Proposed patch

#4 @swissspidy
7 years ago

  • Focuses accessibility added
  • Keywords needs-refresh added
  • Milestone changed from Awaiting Review to Future Release

#5 @sabernhardt
3 years ago

Related/duplicate: #38834

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


17 months ago

#7 @joedolson
17 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #38834.

Closing this as a duplicate.

Note: See TracTickets for help on using tickets.