WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#30801 closed defect (bug) (duplicate)

Editor not Recognizing Line Breaks While Formatting a List

Reported by: semrocc Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: TinyMCE Keywords:
Focuses: Cc:
PR Number:

Description

Since WordPress 4.0, I noticed that the editor no longer recognizes line breaks while setting up a List <li>

Example:

Item 1
Item 2
Item 3

When all items are highlighted and the "li" button in HTML mode is clicked, the following shows:

  • Item 1
    Item 2
    Item 3

Previously, it would format things properly as below:

  • Item 1
  • Item 2
  • Item 3

Also, the editor sometimes thinks the whole post should be within the "li" items when trying to insert a list into a post...its a real challenge to post anything that uses "ul" or "ol".

Change History (11)

#1 @ocean90
5 years ago

  • Component changed from Editor to TinyMCE
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 4.1 to 4.0

Duplicate of #29434.

#2 @semrocc
5 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#3 follow-up: @semrocc
5 years ago

I'm not sure why this bug was marked as closed. Is there any ETA on when this will be fixed?

#4 in reply to: ↑ 3 @Kelderic
5 years ago

Replying to semrocc:

I'm not sure why this bug was marked as closed. Is there any ETA on when this will be fixed?

This has been reported before and it was decided that it works as is. For explanation see:

https://core.trac.wordpress.org/ticket/29434#comment:10

#5 follow-up: @semrocc
5 years ago

So here's a scenario. I create a post in my Notepad Text Editor with a list and then copy and paste it into the WP editor. I then highlight the list as below:

http://www.networkmedia.ca/web2/images/forum-images/txt-1.jpg

Now look at the result after clicking the list button:

http://www.networkmedia.ca/web2/images/forum-images/txt-2.jpg

I certainly would not call this normal behavior as the editor wraps the whole post in a list.

Last edited 5 years ago by semrocc (previous) (diff)

#6 in reply to: ↑ 5 @azaozz
5 years ago

  • Keywords close added

Replying to semrocc:

Can't reproduce this. Pasting 5 lines of plain text (separated by two line breaks after each) properly makes 5 paragraphs in the editor. Then selecting only 3 paragraphs and converting to a list works as expected.

#7 @semrocc
5 years ago

That's strange, I can reproduce it every time. What did you paste the text from?

#8 @semrocc
5 years ago

  • Keywords close removed

#9 @SergeyBiryukov
5 years ago

  • Milestone set to Awaiting Review

#10 @iseulde
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #29434.

Closing the first issue as a duplicate. Do you still experience the second issue? Could you please create a new ticket and give us some more information (exact steps to reproduce and the pasted text) if that's still the case?

#11 @semrocc
5 years ago

Done

#31642

Last edited 5 years ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.