WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#30808 closed defect (bug) (invalid)

WordPress 4.1 comments are not loading when you sign-in to the site

Reported by: writegnj Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Comments Keywords:
Focuses: Cc:

Description

I have experiencing commenting problem after updating WP 4.1 on my multiple WP sites.

Comments are showing up when you are not logged-in but it disappears when you sign-in to site site.

Also, my sites are setup to be able to make comments for registered users. Once they submit their comment, it does not load the comment they just submitted but seems to be the comment goes in to Database.

Change History (6)

#1 @boonebgorges
7 years ago

writegnj - Thanks for the report. Can you share the name of the theme you're using? If it's a custom theme, is it possible for you to share it so that we can test?

Possibly related: #19623

#2 @writegnj
7 years ago

I have same issue on two of my sites using different custom themes. They both are not in WP repository. How do I share my custom themes? I don't mind email them to you or give you the URLs. please let me know!

#3 @boonebgorges
7 years ago

Thanks for the quick response. Please email me at my Trac username AT gmail.com.

#4 @writegnj
7 years ago

Just sent! Let me know if you need anything else.

#5 @writegnj
7 years ago

It seems to be a conflict issue with one of the plug-ins that I use on the site https://wordpress.org/plugins/view-own-posts-media-only/ with WP 4.1.

After deactivating the plug-in, it works just fine.

#6 @boonebgorges
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

writegnj - Thanks very much for following up. As I suspected, this is due to the changes in #19623.

At https://plugins.trac.wordpress.org/browser/view-own-posts-media-only/trunk/includes/class-view-own-posts-media-only.php#L54 the plugin adds a filter to comment queries (when the admin has toggled the setting in question) that will prevent users from seeing others' comments. The way comments were previously queried on the front end of WP meant that this filter was *not* run for that query. My interpretation of the code is that the way it's working now is the way it was originally intended to work - WP 4.1 fixed it. You should be able to fix things by toggling the plugin's "comments" setting; the plugin author should be able to restore the old behavior by wrapping the filter in an is_admin() check or some other appropriate check.

As this appears to be a case where the filter is working as intended, I'm going to close this ticket as invalid. If other cases arise where plugins are doing similar things after 4.1, please feel free to reopen with details and we can reassess.

Note: See TracTickets for help on using tickets.