WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#30809 closed defect (bug) (worksforme)

menu used as "main menu" is simply alphabetical, and setting for main menu is ignored

Reported by: gingerling Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Menus Keywords: reporter-feedback
Focuses: Cc:

Description

After the update to 4.1 our menu "broke" (http://www.pendleheritage.co.uk) - after some investigation I found the problem

We have many menus, but the one for the homepage (at the top) was called main_menu. It was still set as the main menu in appearance > menus > manage locations, however, it was not displaying on the website. Instead another menu was showing.

After some tests I found that the first menu (alphabetically) was the one displayed. In this case that was "archaeology posts" - I deleted that menu and then the menu defaulted to "Conservation events" and so on. As a temporary fix I renamed the main menu to "a menu" so it is the first, alphabetically.

Change History (4)

#2 @nacin
6 years ago

  • Keywords reporter-feedback added
  • Version changed from 4.1 to 3.0

This sounds like a duplicate of #29927, which also appears to be invalid. Perhaps the theme_location argument is not set during the call to wp_nav_menu()?

#3 @swissspidy
5 years ago

  • Keywords close added

#4 @SergeyBiryukov
5 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.