WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#30880 closed defect (bug) (worksforme)

User Cannot Disable Comments on Existing Post after Disabling Comments Site-Wide

Reported by: jelyman Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Comments Keywords:
Focuses: administration Cc:
PR Number:

Description

Discovered this morning with Version 4.1 that after disabling comments site-wide, I was unable to disable comments for an existing post. The Discussion widget is removed from the possible options post-site-wide comment disablement and in order to disable comments for an existing post, I had to re-enable comments, disable the comment for the existing post, then re-disable comments, again. Perhaps better UX can be had in bulk-disabling comments for existing posts or at least still allowing the widget to be chosen in the Editor but with limited functionality (as site-wide comments are disabled).

Change History (3)

#1 @ocean90
5 years ago

  • Focuses ui removed
  • Keywords reporter-feedback added

Hello jelyman, thanks for your report.

I couldn't reproduce the issue. Are you referring to the default article settings on the wp-admin/options-discussion.php screen? Does it still happen with all plugins disabled and a default theme activated? Have you checked the Screen Options tab at the top-right corner?

Related: #27111

#2 @jelyman
5 years ago

  • Keywords reporter-feedback removed
  • Resolution set to worksforme
  • Status changed from new to closed

Ocean90,

Now that you've said that, I can't reproduce the issue, either. The Screen Options didn't feature the Discussion widget as something to choose, originally. I am using Twenty-Fifteen and didn't have plugins enabled at the time. I'll keep an eye on it. Thanks for the response.

#3 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.