WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#30882 closed defect (bug) (duplicate)

Changes to duplicate term not saved

Reported by: cabatint Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Taxonomy Keywords: reporter-feedback
Focuses: Cc:

Description

Created fresh instance (files + database) with 4.1 with no plugins (default theme of twentyfourteen enabled)

Create term "2015" in category - top level category, no parent.
Create term "2015" in tags, successfully saves.
Edit "2015" in tags to add description (no change to other fields). On "save" returns to tags listing page and message "Tag not updated". Viewing term confirms changes not saved.

I can edit the original 2015 term within the category taxonomy to add a description. I cannot edit the later instances of same term in other taxonomies.

Note, I have done the same with new custom taxonomies I've created directly via functions.php on custom post types.

If I change the slug to 2015a in tags, the changes saved. If I attempt to change the slug 2015a back to 2015 I get a "tag not updated" message on the tag listing page.

I cannot change "2015" slug in category to "2015a" when it's already used in tags. I get a "Category not updated" message on return. I can change it to "2015b" successfully and then back to "2015" successfully. (Again, no duplication in tags)

I've also tried the same behaviors with a term of "abc" between category and tabs, which has the same behavior.

Change History (3)

#1 @ocean90
6 years ago

  • Keywords reporter-feedback added

Hello cabatint, thanks for your report.

Can you please take a look at #30780 and verify if the issue still exists in current trunk/nightly?

#2 @cabatint
6 years ago

Downloaded the nightly 4.2 using the beta testing plugin and it looks like it's working. Can change descriptions on the duplicate term and switch in/out the slug.

I looked for a related recent ticket that covered this but didn't see this one.

#3 @boonebgorges
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #30780.

Thanks for verifying, cabatint!

Note: See TracTickets for help on using tickets.