WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#30901 closed feature request (duplicate)

Add improved graphics on updating/installing theme/plugin

Reported by: Fattdev Owned by:
Milestone: Priority: normal
Severity: minor Version: 4.1
Component: Upgrade/Install Keywords:
Focuses: ui, template Cc:

Description

When you go to install a theme, you see;

"Downloading"
Etc.

I think we instead should have a css3 loading spinner, as the process in about only 2/3 seconds. If you agree, please tell me, and I will create what I think.

What do you think?

Change History (5)

#1 @Fattdev
4 years ago

  • Component changed from General to Upgrade/Install
  • Severity changed from normal to minor

#2 @Fattdev
4 years ago

Just tried created something, to start from: http://codepen.io/fattdev/pen/RNoxPm

#3 follow-up: @vimes1984
4 years ago

I'd love to see a progress bar maybe html5 (https://developer.mozilla.org/en-US/docs/Web/HTML/Element/progress)
Since I've just had a issue on a slow server where the installs took ages and I was unable to tell if it was working or just hanging..

#4 in reply to: ↑ 3 @Fattdev
4 years ago

Replying to vimes1984:

I'd love to see a progress bar maybe html5 (https://developer.mozilla.org/en-US/docs/Web/HTML/Element/progress)
Since I've just had a issue on a slow server where the installs took ages and I was unable to tell if it was working or just hanging..

Totally, a styled HTML5 progress, certainly has great browser support. http://caniuse.com/#feat=progressmeter I will look into creating this first things tomorrow!

#5 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hello Fattdev,

instead of doing cosmetic tweaks we're trying to remove these screens altogether, see http://make.wordpress.org/core/2014/10/08/ideas-for-plugin-theme-installs-updates/. Maybe you want to help us with that?

Closing as a duplicate of #29820.

Note: See TracTickets for help on using tickets.