WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#30919 closed defect (bug) (duplicate)

Unexpected Behavior of End / PgUp / PgDn Buttons in TinyMCE & Distraction Free Writing Mode

Reported by: mrwweb Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Editor Keywords:
Focuses: ui, javascript, administration Cc:

Description

When entering the new 4.1 Distraction Free Writing (DFW) mode, the behavior of the End, Page Up, and Page Down keys has the potential to unintentionally exit DFW and the editor.

All the keys (at least in my testing of Windows 8.1 / Chrome) are manipulating the full page and not just the editor, despite the fact that the editor has focus and appears to be the only UI when DFW is enabled.

Specifically, this means that the End key jumps to the end of the page as seen without DFW on and exiting DFW mode (potentially without the editor even visible if there are enough elements below the page editor).

Page Up and Page Down both seem to manipulate the page and cursor position under the assumption that the editor is at most 100% of the height of the page. If the post is longer than that, then the cursor will jump to some point near the end of the post or exist DFW mode entirely.

Since DFW enters a mode akin to a document editor, I expected those keys to work within the TinyMCE editor and not the full page itself whenever the editor has focus and DFW is enabled.

I believe these problems also occur when DFW is not enabled (so maybe it's really an issue with the full-height editor?); however, the effect is much more jarring and unexpected when DFW is on.

Change History (3)

#1 @archon810
5 years ago

Just filed a similar ticket, but one that applies to the regular edit mode rather than the distraction-free mode: #31751.

#2 @mrwweb
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #31751.

After a bit of testing, I think these are actually duplicate. This bug isn't only in DFW, that was my mistake. It seems to be a full-height editor issue.

I'm going to mark this as a duplicate.

#3 @DrewAPicture
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.