Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#30931 closed defect (bug) (fixed)

Remove date dropdown from Edit Selection mode

Reported by: pavelevap's profile pavelevap Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 4.2 Priority: normal
Severity: normal Version: 4.2
Component: Media Keywords: has-patch
Focuses: ui, administration Cc:

Description

I selected 2 images from media library (uploaded during November 2014). Click "Edit Selection" and you can see that there is date dropdown with preselected value from December 2013. Date dropdown is misleading (and wrong) in this place. See attached screenshot.

Attachments (2)

Misleading_date_dropdown.png (98.7 KB) - added by pavelevap 10 years ago.
30931.patch (402 bytes) - added by tyxla 10 years ago.
Removing the date filter from the "Edit Selection" screen.

Download all attachments as: .zip

Change History (13)

#1 @SergeyBiryukov
10 years ago

  • Focuses ui administration added
  • Milestone changed from Awaiting Review to 4.2

#2 @dmchale
10 years ago

Strange question, is this core? I don't have the ability to "edit selection" when doing a Bulk Select, I only have cancel/delete options. I'm unable to replicate this on my end, unless I'm looking in the wrong place.

#3 @helen
10 years ago

I believe this is referring to the modal.

#4 @tyxla
10 years ago

  • Keywords needs-patch added

I confirm that this defect is present.

Steps to reproduce:

  1. In the administration, open a post of any post type that has an editor.
  2. Click "Add Media" to upload new a couple of images.
  3. After the images have been uploaded, make sure they are selected.
  4. Once more than 2 images are selected, click the "Edit Selection" button at the bottom of the screen.
  5. This brings up the reported screen.

Indeed, there is a "Date" filter that does nothing and should not be there, as this screen is for reordering the selected media items.

@tyxla
10 years ago

Removing the date filter from the "Edit Selection" screen.

#5 @tyxla
10 years ago

  • Keywords has-patch added; needs-patch removed

#6 follow-up: @SergeyBiryukov
10 years ago

This has an additional bonus of showing the "Drag and drop to reorder images" string (previously hidden).

#7 @SergeyBiryukov
10 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 31096:

Remove non-functional date filter from Edit Selection view in media modal.

props tyxla.
fixes #30931.

#8 in reply to: ↑ 6 @pavelevap
10 years ago

Replying to SergeyBiryukov:

This has an additional bonus of showing the "Drag and drop to reorder images" string (previously hidden).

Yes, never noticed it before :-) But this string is not accurate, because you can reorder also for example video files, so maybe "Media files" should be better?

#9 @SergeyBiryukov
10 years ago

In 31102:

Make a hint on Edit Selection view in media modal more accurate, as it applies to all media files, not just images.

props pavelevap.
see #30931.

#10 follow-up: @pavelevap
9 years ago

@SergeyBiryukov: We had "Drag and drop to reorder images." string which is now "Drag and drop to reorder media files." not only for Edit Selection modal, but also for Create Gallery. Maybe we can make this string universal and replace also "Drag and drop to reorder tracks." and "Drag and drop to reorder videos." with general term "media files"? Or we should create new string "Drag and drop to reorder images." for Create Gallery part to be consistent?

#11 in reply to: ↑ 10 @SergeyBiryukov
9 years ago

Replying to pavelevap:

I think I would prefer a new string for Create Gallery. Let's create a new ticket :)

Note: See TracTickets for help on using tickets.