Make WordPress Core

Opened 10 years ago

Closed 9 years ago

#30985 closed defect (bug) (duplicate)

Cutting and pasting of image strips "Link to" and changes it to "None"

Reported by: archon810's profile archon810 Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Hi,

I'm observing the following bug with images on Wordpress 4.1.

Chrome 39 stable on Windows 8.1 x64.

Insert an image thumb into a post and have the thumb link to the Media file, meaning the larger version of itself.

Now select the image, press ctrl-X to cut it, and then paste it back. Edit the image again, and you'll see that "Link to" has been changed to "None," meaning it lost the link to the full version.

Curiously, copy-pasting retains the link, only cutting and pasting removes it.

Here is a quick GIF of the bug in action. Here, I cut and paste back the image: http://i.imgur.com/9QjKwHm.gif.

Change History (3)

#1 @iseulde
10 years ago

Related: #28272.

#2 @archon810
10 years ago

  • Severity changed from normal to major

Any updates? This is tripping us up almost every day, with images ending up without links to larger versions and just unclickable thumbnails. A pretty bad user-facing bug if I may say so myself.

#3 @iseulde
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.1 deleted

Duplicate of #28272.

Note: See TracTickets for help on using tickets.