WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#31004 closed enhancement (duplicate)

Support srcset in avatars.

Reported by: georgestephanis Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: General Keywords: needs-refresh reporter-feedback
Focuses: Cc:

Description

With the recent commits of [31107] and [31152] on #21195 we can more easily roll in native srcset support to avatars throughout WordPress! (yay responsive images)

Patch attached.

Attachments (1)

add-srcset-to-avatars.diff (2.3 KB) - added by georgestephanis 5 years ago.

Download all attachments as: .zip

Change History (8)

This ticket was mentioned in Slack in #feature-respimg by georgestephanis. View the logs.


5 years ago

#2 @pento
5 years ago

I'm definitely in favour of adding srcset support, though I have a couple of reservations about this patch.

  • Browser support is currently at ~50%. I think we'd need to provide a shim for compatibility with all browsers. (I haven't investigated the current state of such shims.)
  • The code for generating the sizes seems more appropriate as part of the responsive-images plugin. I don't really want to preempt the work done in that plugin, when we're relatively close to a global solution.

I'd like to see this land in the feature plugin first. If there are any extra filters required, we can probably add them in (either temporary or permanent, as needed).

#3 @iseulde
5 years ago

Can we keep this discussion in #22329?

#4 @miqrogroove
5 years ago

The biggest problem I see here is that the size and url args were both made filterable already. This patch assumes that the size arg corresponds to the 1x size for the url arg, which is no longer a valid assumption.

#31469 might be a step in the right direction, and even that might need to be expanded to keep all the different variables separated.

#5 @iseulde
5 years ago

  • Keywords needs-refresh reporter-feedback added; has-patch removed

Do we still need to do anything here after [31721]?

#6 @miqrogroove
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22329.

I suggest starting a new ticket if there are any stragglers.

#7 @helen
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.