WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#31019 closed defect (bug) (duplicate)

Critical Bug: Special Emoji character destroys draft

Reported by: Justin.Reinhart Owned by:
Milestone: Priority: normal
Severity: critical Version: 4.1
Component: Database Keywords:
Focuses: Cc:
PR Number:

Description

In WordPress 4.1, editing a draft via Chrome browser in Windows 7, it is possible to lose a draft if the contents of the Visual editor contain a specific type of special character. Basically, the character is an iPhone Emoji.

I had sent an email to a company for support from my iPhone and I used an Emoji that does not show up when it reaches the PC. When you view the sent email from the PC, in Gmail, the Emoji shows up as a square. (

Change History (6)

#1 follow-up: @Justin.Reinhart
5 years ago

It looks like my bug report was truncated. Go here for full description:
https://core.trac.wordpress.org/ticket/31019

#2 @Justin.Reinhart
5 years ago

  • Severity changed from normal to critical

#3 @Justin.Reinhart
5 years ago

It looks like my bug report was truncated. Go here for full description:
https://wordpress.org/support/topic/critical-bug-special-emoji-character-destroys-draft

Quote:
In WordPress 4.1, editing a draft via Chrome browser in Windows 7, it is possible to lose a draft if the contents of the Visual editor contain a specific type of special character. Basically, the character is an iPhone Emoji.

I had sent an email to a company for support from my iPhone and I used an Emoji that does not show up when it reaches the PC. When you view the sent email from the PC, in Gmail, the Emoji shows up as a square. (

#4 in reply to: ↑ description @Justin.Reinhart
5 years ago

Yeah! Ironically this character also truncates the description that I entered via Trac! So maybe consider submitting the bug to Trac too.

#5 @pento
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21212.

Thanks for the bug report! This is fixed in trunk, and will be released in WordPress 4.2.

We're also looking ways to make emoji play nicer in WordPress, so you'll be able to use them in your posts. :-)

#6 in reply to: ↑ 1 @SergeyBiryukov
5 years ago

  • Component changed from Editor to Database

Replying to Justin.Reinhart:

It looks like my bug report was truncated.

Yep, see #meta386 for the Trac issue.

Note: See TracTickets for help on using tickets.