WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#31035 closed defect (bug) (duplicate)

Polish diacritics cannot be inputted on Mac OS X in visual editor

Reported by: dragonee Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Tested with newest current download of Wordpress (I have tested pl_PL version downloaded from pl.wordpress.org) with Safari, Chrome and Firefox on Mac OS X Yosemite 10.10.1.

On Mac OS X, Polish diacritics like Ł Ń Ś cannot be inputted in the editor. This is due the fact that TinyMCE does not distinct between Option_L and Option_R, like between Alt and AltGr on Windows. On Polish Programmer's keyboard sequences to input these diacritics are Option+Shift+(letter), and file wp-includes/js/tinymce/plugins/wordpress/plugin.js defines shortcuts as:

412     modKey = 'alt+shift';
413
414     editor.addShortcut( modKey + '+c', '', 'JustifyCenter' );
415     editor.addShortcut( modKey + '+r', '', 'JustifyRight' );
416     editor.addShortcut( modKey + '+l', '', 'JustifyLeft' );
417     editor.addShortcut( modKey + '+j', '', 'JustifyFull' );
418     editor.addShortcut( modKey + '+q', '', 'mceBlockQuote' );
419     editor.addShortcut( modKey + '+u', '', 'InsertUnorderedList' );
420     editor.addShortcut( modKey + '+o', '', 'InsertOrderedList' );
421     editor.addShortcut( modKey + '+n', '', 'mceSpellCheck' );
422     editor.addShortcut( modKey + '+s', '', 'unlink' );
423     editor.addShortcut( modKey + '+m', '', 'WP_Medialib' );
424     editor.addShortcut( modKey + '+z', '', 'WP_Adv' );
425     editor.addShortcut( modKey + '+t', '', 'WP_More' );
426     editor.addShortcut( modKey + '+d', '', 'Strikethrough' );
427     editor.addShortcut( modKey + '+h', '', 'WP_Help' );
428     editor.addShortcut( modKey + '+p', '', 'WP_Page' );
429     editor.addShortcut( modKey + '+x', '', 'WP_Code' );

The Option key is then catched as 'alt' by the editor and diacritics cannot be inputted. For the note, they can be both pasted in the Visual Editor and inputted/pasted in Text Editor, so the problem affects only the Visual Editor.

This affects all current install of Wordpress for Polish Mac users. As far as I know, there is also no option to disable these shortcuts in the administration panel.

Change History (2)

#1 @helen
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29558.

#2 @dragonee
7 years ago

Sorry for posting duplicate issue and thanks for quick response, I haven't thought about searching for Alt and Shift keywords in the search box.

Note: See TracTickets for help on using tickets.