WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#31075 closed feature request (duplicate)

Customizer Global Reset

Reported by: nvartolomei Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Customize Keywords:
Focuses: Cc:

Description

Hello,

Why we still don't have a reset button along with save? This would be very useful.

I came up with the following method of resetting everything:

  1. hook to wp_loaded (there we are pretty sure everyone registered their settings with customizer)
  2. look under each settings
  3. a) if it is a theme_mod just remove it
  4. b) if is an option check if it not one of WordPress' fields and remove them too

Another way (maybe better) would be to set them up with settings default value if one exists.

What do you think?

Change History (2)

#1 @nvartolomei
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21666.

#2 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.