WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#31096 closed defect (bug) (duplicate)

System fails to revert to next "default" theme if default theme folder is renamed or deleted

Reported by: randywsandberg Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Themes Keywords:
Focuses: Cc:

Description

Currently, when one changes the name of an active non-default WordPress theme the system reports, "The active theme is broken. Reverting to the default theme." And after a page reload, the default theme is displayed as active (see screenshots 1–3). But, what happens if one changes the name (or deletes) the default theme's folder? That's what my colleague and I wanted to find out.

Setup:

  • WordPress 4.1
  • Active theme (default theme): Twenty Fifteen
  • Other themes installed (shipped with): Twenty Fourteen, Twenty Thirteen
  • Mac Chrome 40.0.2214.91 (64-bit)

Steps:

  1. Via FTP, either delete or rename twentyfifteen folder (e.g., -twentyfifteen)
  2. Log in as admin (/wp-admin)
  3. Go to Appearance > Themes

--> bug (or at least an enhancement request!)

Expected, as can be seen when any other theme's folder is modified or removed, WordPress to revert back to the default theme (i.e., in this case Twenty Fourteen would make sense).

Instead, the system reports "ERROR: The theme directory "twentyfifteen" does not exist." and that's it. No recovery of any kind (see screenshots 4 and 5), other than by user intervention.

Reproducible? Always

Occurs:

  • Mac Chrome 40.0.2214.91 (64-bit)
  • Mac Firefox 35.0

Attachments (5)

Screenshot 1.png (315.6 KB) - added by randywsandberg 7 years ago.
Screenshot 2.png (316.7 KB) - added by randywsandberg 7 years ago.
Screenshot 3.png (318.0 KB) - added by randywsandberg 7 years ago.
Screenshot 4.png (318.6 KB) - added by randywsandberg 7 years ago.
Screenshot 5.png (316.7 KB) - added by randywsandberg 7 years ago.

Download all attachments as: .zip

Change History (6)

#1 @ocean90
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28645.

Note: See TracTickets for help on using tickets.