WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#31107 closed defect (bug) (wontfix)

'Comment must be manually approved' and the moderation keyword box do not stop contributor-level comments on their own posts.

Reported by: Cantdosleepy Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Comments Keywords:
Focuses: Cc:
PR Number:

Description

Some comments bypass moderation, even when the 'Comment must be manually approved' is checked and the comments contain the moderation-greylisted words.

Process to recreate bug:

I created a fresh installation of WordPress with no plugins activated, using the twentyfifteen theme.
I clicked 'comments must be manually approved'.
I created a brand new contributor.
I commented on the 'Hello World' post as the test contributor.
I created a draft post as the test contributor.
Both of these went into the moderation queue – great!
I logged in as admin and approved the pending post and comment.
Now as a test contributor I can comment on my own post, bypassing both the 'all comments must be manually approved' queue, and also the comment moderation keyspace.

Change History (1)

#1 @rachelbaker
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

@Cantdosleepy,

This is actually by design. The wp_allow_comment() function allows the post_author to comment on their own posts. You can use the pre_comment_approved filter to change this behavior for your site.

I agree that the "Comments must be manually approved" option is misleading, but I hesitate to change the current behavior.

Note: See TracTickets for help on using tickets.