WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#31133 closed defect (bug) (wontfix)

Distraction-free writing is anything but when editing and reviewing

Reported by: stringfold Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Editor Keywords:
Focuses: ui, administration Cc:

Description

As a frequent user of the older version of distraction-free writing mode, I was dismayed to find it had been replaced by far more distracting functionality that seems to have ignored the fact that much of the work involved in creating new posts and pages involves as much editing and reviewing as it does writing.

I can understand the utility of the feature if all you are doing is writing a post. As long as you keep typing in the editor, the rest of the controls remain hidden. However, once you start reviewing and editing your work, which often involves frequent use of the scroll bar and Page Up and Page Down buttons, the way the menus and sidebars pop in and out all the time is extremely distracting, as is the fact that you don't go back into distraction-free mode until you actually type something into the editor (i.e. clicking into the editor doesn't hide the controls).

Here is the list of regressions from the old functionality seen in the new distraction-free mode:

  • Use of the scroll bar while in distraction-free mode now causes a major distraction since it is impossible to reach it without causing the menus to slide in from the left (HCI-experts will tell you how distracting this movement is) and the controls on the right to appear. This happens even if you still want to be entirely focused on the piece you are writing and have no need to use the menus or controls. Perhaps you just want to review what you just wrote, or maybe you want to go back and move text around.
  • The fact that the menus and controls remain visible until you actually start typing again compounds the problem. If you're in the middle of reviewing a long piece, you may only be fixing the occasional grammatical error or spelling mistake. The rest of the time you're just reading and scrolling, so the menus and controls will remain visible the vast majority of the time, making distraction-free mode virtually useless. This behavior is also counter-intuitive, since it is asymmetric in nature. Moving the mouse away from editor reveals the controls and menus, but moving it back does not. Surely the assumption must be that you want to see the controls and menus as infrequently as possible?
  • Even if you stick to the page up and page down buttons, you can find yourself being distracted by the menus and controls appearing for no good reason. The problem happens when you scroll to the bottom of the piece using page down. When you reach the bottom of your post, the editor window may only extend part way down the page, and if your mouse pointer is below that (i.e. over an invisible control) the menus and controls will pop into view unexpectedly, and you can't get rid of them again until you type something into the editor window.
  • Finally, the new version of the mode requires that space is reserved for the menus and controls to appear no matter how narrow the browser window. Therefore, the browser window's minimum width has to be almost 50% wider than it used to be when using the old distraction-free mode if you want to edit your work at the standard width. I would also consider this a major regression from the old version of the mode.

The bottom line is that the new distraction-free mode actually causes more distractions, especially when you are reviewing and editing posts (which is a lot of the time). Something as simple as accessing the scroll bar or even just moving the pointer away from the editor (you might be wanting to click on something outside the browser) should not cause animations and fade-ins to occur.

I have raised these issues as a bug report and not an enhancement request because the changes to distraction-free mode have causes major regressions to an existing feature. I only wish I had been aware of the proposed changes before they were added to WordPress.

Change History (3)

This ticket was mentioned in Slack in #feature-focus by iseulde. View the logs.


7 years ago

#2 @SergeyBiryukov
7 years ago

Found a plugin that restores pre-4.1 DFW as a separate writing mode: https://wordpress.org/plugins/just-writing/.

Last edited 4 years ago by SergeyBiryukov (previous) (diff)

#3 @danielbachhuber
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Hi @stringfold,

Thanks again for taking the time to write up your concerns in this ticket.

If you're still working with WordPress, Gutenberg is the project's primary editorial focus. There's an installable WordPress.org version you can try locally. I know that this level of usability feedback would be very much appreciated — GitHub issues on the first link are the most appropriate place.

Note: See TracTickets for help on using tickets.