WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#31142 closed defect (bug) (invalid)

GUIDs are not compiling properly.

Reported by: DaveyJake Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

I'm developing a website for my rugby club on a MacBook Pro using MAMP, Sequel Pro, CodeKit and Sublime Text 3. For some reason I'm getting 404 errors only on post_types. When looking at my database, I notice that my GUIDs are not rendering like they have in other projects.

Instead of seeing http://localhost:7888/my-project/?p=20 in my GUID column, I end up with http://localhost:7888/my-project/?post_type=team&p=20.

Does anyone know of a simple fix for this? I've never encountered this issue before on any of my projects. To create custom post types, I'm using Custom Post Type UI in combination with ACF Pro (which I've always done). I've also set my permalinks to render by %postname%.

Any advice would be greatly appreciated.

Thanks, everyone!

Change History (2)

#1 @DaveyJake
7 years ago

  • Focuses ui javascript removed
  • Keywords needs-patch added

#2 @ocean90
7 years ago

  • Component changed from Database to Posts, Post Types
  • Focuses accessibility template removed
  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Please try the Support Forums for troubleshooting first.

Feel free to reopen with more details and steps to reproduce on a clean install if it turns out to be a bug in core.

Note: See TracTickets for help on using tickets.