WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#31160 closed defect (bug) (duplicate)

wptexturize(): quotation mark rendered incorrectly after link, before parenthesis

Reported by: paulschreiber Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Formatting Keywords:
Focuses: Cc:

Description

The following text is rendered incorrectly:

(foo bar "<a href="http://www.chargers.com/">K balls</a>")

Expected:

(foo bar “K balls”)

Actual:

(foo bar “K balls“)

If you remove either the link or the trailing parenthesis, it renders a close quote, as expected.

Change History (4)

#1 @DrewAPicture
7 years ago

  • Component changed from General to Formatting

#2 @SergeyBiryukov
7 years ago

  • Summary changed from wptextureize(): quotation mark rendered incorrectly after link, before parenthesis to wptexturize(): quotation mark rendered incorrectly after link, before parenthesis

#3 @miqrogroove
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18549.

#4 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.