WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#31170 closed defect (bug) (fixed)

TinyMCE view edit tooltip can conflict with TinyMCE tollbar

Reported by: danielbachhuber Owned by:
Milestone: 4.2 Priority: normal
Severity: normal Version: 4.1
Component: TinyMCE Keywords: has-patch
Focuses: javascript Cc:

Description

See screenshot:

https://dl.dropboxusercontent.com/s/sejq4amcfvq1cmk/2015-01-28%20at%202.50%20PM.png

This particular view was added with Shortcake, so it might be a problem there. I can reproduce somewhat consistently when I switch between HTML and Visual.

Previously: https://github.com/fusioneng/Shortcake/issues/84

Change History (9)

#1 @SergeyBiryukov
7 years ago

  • Component changed from Editor to TinyMCE

#2 @iseulde
7 years ago

  • Focuses javascript added
  • Keywords needs-patch added

The toolbar for the views is a bit different from image toolbar. Ideally it also needs to be using the TinyMCE API. I remember @azaozz changed the style of the old buttons a bit to make it look like the image toolbar, but it's not ideal. Maybe better to redo this with the API to fix this so both toolbars use the same code.

#3 @iseulde
7 years ago

See also #30619.

#4 @iseulde
7 years ago

@danielbachhuber can you reproduce this with a core shortcode? I thought I reproduced this earlier, but now I fail.

And what else is happening with the view? The bottom seems to be cut of and normally you shouldn't see the toolbar if the view isn't selected. Or did you change the styles?

#5 @iseulde
7 years ago

  • Keywords reporter-feedback added

#6 @danielbachhuber
7 years ago

can you reproduce this with a core shortcode? I thought I reproduced this earlier, but now I fail.

I'll see if I can get better reproduction steps :/ I haven't been able to reproduce it consistently, but it does happen regularly.

#7 @iseulde
7 years ago

  • Milestone changed from Future Release to 4.2

This needs to be looked at.

#8 @iseulde
7 years ago

  • Keywords has-patch added; needs-patch reporter-feedback removed
  • Version set to 4.1

The patch added to #30619 will fix this.

#9 @iseulde
7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [31725].

Note: See TracTickets for help on using tickets.