WordPress.org

Make WordPress Core

Opened 13 years ago

Closed 13 years ago

#3118 closed defect (bug) (fixed)

Autop no longer working on posts

Reported by: ketsugi Owned by:
Milestone: 2.1 Priority: high
Severity: major Version: 2.1
Component: Template Keywords:
Focuses: Cc:
PR Number:

Description

After updating from 4174 to 4178, I noticed that auto-paragraphing was no longer in effect on my item posts, although it still works in comments. I'm not sure if this is reproducible, as I asked around in #wordpress and no other svn user seemed to have the same problem. However I'm at a loss as to why this might be the case, and I'm hoping that it's due to some error on my part rather than a bug in the code, but I can't be too sure.

The issue can be seen at http://ketsugi.com

Change History (11)

#1 @ketsugi
13 years ago

  • Owner changed from anonymous to ketsugi
  • Status changed from new to assigned

Reverting to 4174 has fixed the issue so the issue can no longer be seen on my blog, but the symptoms remain as reported above.

#2 @ketsugi
13 years ago

  • Owner ketsugi deleted
  • Status changed from assigned to new

#3 @Viper007Bond
13 years ago

  • Component changed from Administration to Template
  • Milestone set to 2.1
  • Priority changed from normal to high
  • Resolution set to worksforme
  • Severity changed from normal to major
  • Status changed from new to closed

Deactivate plugins? Try default theme? Something must be conflicting as it works perfectly fine for me with a clean copy of the SVN with no real plugins installed.

#4 @ketsugi
13 years ago

You're right; it is a plugin problem. However it seems that multiple plugins are causing this problem. My best guess is that it has to do with [4176] and any plugin that uses add_action, as this seems to be the common deminominator with the plugins that I found causes the problem.

I'm assuming for now that this is desired behavior, so I'm leaving this ticket closed.

#5 @ketsugi
13 years ago

I did some further testing and can now confirm that it is actually [4177] that is causing the problem. Again, plugins are not broken, but the autop somehow gets turned off whenever one of these plugins is activated.

As before, I'm not sure if this is considered a bug, or if it is desired behaviour. If it is desired behaviour, may I request some documentation on [4177] so I know how to modify the plugins to prevent this autop breakage?

#6 @ryan
13 years ago

How is add_action() being used? What do the calls to it look like?

#7 @ryan
13 years ago

Which plugins are you using?

#8 @Viper007Bond
13 years ago

It must be some funky old ones or something because none of the plugins that I have activated break my v2.0.4 blog.

#9 @ketsugi
13 years ago

Viper007Bond: This ticket is for 2.1, with specific regard to [4177].

Two of the specific plugins I noticed which individually caused the breakage are my own Acronyms plugin and the Ultimate Tag Warrior plugin. I think mine is the simpler of the two. The relevant add_action calls are thus:

add_action( 'activate_acronyms.php', array( 'Acronyms', 'install' ) );
add_action( 'deactivate_acronyms.php', array( 'Acronyms', 'uninstall' ) );
if (1 == get_option( 'acronym_content' ) )
	add_filter( 'the_content', array( 'Acronyms', 'acronym_replace' ) );
if (1 == get_option( 'acronym_comments' ) )
	add_filter( 'comment_text', array( 'Acronyms', 'acronym_replace' ) );
add_action( 'admin_head', array( 'Acronyms', 'manage_acronyms_css') );
add_action( 'admin_menu', array( 'Acronyms', 'add_pages' ) );

The

#10 @Viper007Bond
13 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

You're right, I'm sorry. I dunno where I got the idea 2.0.4 was in play. Sorry about that. :/

Oh, and this is a filter, not an action issue. ;)

Anyway, I just noticed that while my local SVN blog is not affected (Windows), my online test blog is (*nix). From what I can see, the plugins that have the issue is ones in which the referenced function for the filter is inside a PHP class.

#11 @ryan
13 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4179]) Pass along the modified string instead of the original. fixes #3118

Note: See TracTickets for help on using tickets.