WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#31272 closed defect (bug) (duplicate)

"Collapse menu" menu item does not contain a link, hence, it is not accessible/focusable via keyboard

Reported by: ipm-frommen Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: accessibility, administration Cc:

Description

The attached patch refactors the Collapse menu menu item:

  • add link, and thus make item accessible/focusable via keyboard;
  • use dashicons;
  • avoid CSS overload.

Note: Yes, I did see ticket #29958, and it is related. However, both what is being targetted and the solutions (i.e., patches) differ. And there is also a discussion going on that I didn't want to jump into. Feel free to either close this or merge the tickets, if you want to.

Attachments (2)

31272.patch (5.5 KB) - added by ipm-frommen 4 years ago.
31272-2.patch (5.5 KB) - added by ipm-frommen 4 years ago.
Actually apply font-size

Download all attachments as: .zip

Change History (4)

@ipm-frommen
4 years ago

#1 @ipm-frommen
4 years ago

  • Keywords has-patch 2nd-opinion added

@ipm-frommen
4 years ago

Actually apply font-size

#2 @helen
4 years ago

  • Keywords has-patch 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Ideally, a Trac ticket is about the problem and not one given solution. If you're used to GitHub, it's more equivalent to an issue than a pull request. So yes, it is a duplicate of #29958 - please do upload your patch there, though.

Note: See TracTickets for help on using tickets.