WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#31366 closed defect (bug) (duplicate)

TinyMCE wpeditimage floatingToolbar.reposition compatibility for multiple editors

Reported by: elliotcondon Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: TinyMCE Keywords:
Focuses: javascript Cc:
PR Number:

Description

Hi guys

I think the floatingToolbar.reposition function within the tinymce wpeditimage plugin no longer contains compatibility for multiple editors on the page.

When multiple editors exist (custom field plugin) and you click on an image (with an editor), the floatingToolbar appears at the very top of the page under the admin menu.

This worked correctly in WP4.0, but since 4.1 the issue exists.

Please note that when the image contains enough space above above, the toolbar will display correclty, it is only when there is not enough space between the image and the WYSIWYG toolbar that the bug occurs

Thanks
E

Attachments (1)

Screen Shot 2015-02-18 at 1.46.16 pm.png (200.6 KB) - added by elliotcondon 5 years ago.
Screenshot of bug

Download all attachments as: .zip

Change History (5)

#1 @iseulde
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #31028.

Thanks! Will be fixed in WP 4.1.1.

#2 @elliotcondon
5 years ago

Thanks guys. Sorry for the duplicate post :)

#3 @helen
5 years ago

We're just happy to see you on Trac. :)

#4 @SergeyBiryukov
5 years ago

  • Summary changed from TinyMCE wpeditimage floatingToolbar.reposition compatibiliyt for multiple ediitors to TinyMCE wpeditimage floatingToolbar.reposition compatibility for multiple editors
Note: See TracTickets for help on using tickets.