WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#31370 closed defect (bug) (duplicate)

Select/edit post unclear in edit.php for a screen reader user

Reported by: rianrietveld Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords:
Focuses: accessibility, administration Cc:

Description

In edit.php there is the table with the listing of the posts.
Per row the title of the post is read out 3 times after each other, and for screen reader users it's not clear what the meaning or difference is

<tr id="post-95" class="iedit author-self level-0 post-95 type-post status-publish format-standard hentry category-uncategorized">
	<th scope="row" class="check-column">
		<label class="screen-reader-text" for="cb-select-95">Select test</label>
		<input id="cb-select-95" type="checkbox" name="post[]" value="95">
		<div class="locked-indicator"></div>
	</th>
	<td class="post-title page-title column-title">
		<strong>
			<a class="row-title" href="[...]/wp-admin/post.php?post=95&amp;action=edit" title="Edit “test”">test</a>
		</strong>
		<div class="locked-info"><span class="locked-avatar"></span> <span class="locked-text"></span></div>
		<p>The excerpt of Test here...</p>
		<div class="row-actions">
			<span class="edit"><a href="[...]/wp-admin/post.php?post=95&amp;action=edit" title="Edit this item">Edit</a> | </span>
			<span class="inline hide-if-no-js"><a href="#" class="editinline" title="Edit this item inline">Quick&nbsp;Edit</a> | </span>
			<span class="trash"><a class="submitdelete" title="Move this item to the Trash" href="http://pctje.xs4all.nl/trunk/src/wp-admin/post.php?post=95&amp;action=trash&amp;_wpnonce=33cbe221df">Trash</a> | </span>
			<span class="view"><a href="[...]" title="View “test”" rel="permalink">View</a></span></div>
		
	[...]

</tr>

A screen reader user hears in NVDA:
row 2 Select All column 1
Select postname check box not checked
Title column 2
postname link Edit “postname”
Edit link Edit this item
Quick Edit link Edit this item inline
Trash link Move this item to the Trash
View link View “postname”

It is not clear what those 3 different items mean: Select postname & Edit “postname” & Edit this item

The reading of select all before every row will be discussed in a separate ticket.

In fact Edit “postname” or Edit this item are links to the same page. This is also confusing for sighted users is my experience. Why 2 links to the same page (/wp-admin/post.php?post=xx&action=edit).

It would be clearer if the first checkbox and Edit “postname” would be properly screen-reader-text labeled and the third link deleted all together.

Change History (4)

#1 @SergeyBiryukov
6 years ago

  • Component changed from Administration to Posts, Post Types
  • Focuses administration added

#2 @DrewAPicture
5 years ago

  • Version trunk deleted

#3 @afercia
5 years ago

Related: #32254

#4 @rianrietveld
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Related (duplicate of) #33002

Note: See TracTickets for help on using tickets.