WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#31386 closed enhancement (duplicate)

Add `target="_blank"` to WordPress.org links in dashboard.

Reported by: michael.ecklund Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Administration Keywords:
Focuses: administration Cc:
PR Number:

Description

It would be nice if all links in the backend which link to wordpress.org, open in a new tab automatically... Instead of taking the user away from managing their website.

Change History (5)

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


4 years ago

This ticket was mentioned in Slack in #accessibility by rianrietveld. View the logs.


4 years ago

#4 @davidakennedy
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

We're going to close this, but work on this issue in another ticket. We talked about a handful of these "open new window" tickets as an accessibility team, and came to these conclusions:

  • no links should open in a new window (to be consistent throughout the Admin)
  • already made settings might be lost, so before following a link, the user must be warned like: “there are unsaved changes….”
  • an alternative, but complex solution would be that settings are auto saved before leaving a window
  • we should do a search on all links that open in a new window in the Admin

We'll comment with tickets #31363 and #31386, suggesting to close them. And continue to work on this issue further with ticket #23432.

@michael.ecklund Thanks for the bug report! If you want to continue work on this issue, head over to #23432.

#5 @DrewAPicture
4 years ago

  • Milestone Awaiting Review deleted

Duplicate of #23432.

Note: See TracTickets for help on using tickets.