Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#31397 closed defect (bug) (duplicate)

Bug in custom post type

Reported by: lutond's profile lutond Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

When show_id is false then this post type shows invalid post type. Every thing is correct only change to false from true you will show this error.

Attachments (2)

post.types.php (3.2 KB) - added by lutond 9 years ago.
This file is not initialized. I initialized it using init action.
custom-post-type-4.1.1.php (3.1 KB) - added by lutond 9 years ago.
Second upload - edited

Download all attachments as: .zip

Change History (7)

@lutond
9 years ago

This file is not initialized. I initialized it using init action.

#1 @helen
9 years ago

  • Keywords reporter-feedback added

What is show_id? Where does it show "invalid post type"? Is this new in 4.1.1, the version you selected?

#2 @lutond
9 years ago

Oops! Sorry, it is show_ui not show_id. Latest code of the full plugin is attached again after editing all necessary codes. Install it and go to the following link. Than you will understand what i am saying. Thanks.

http://your-domain/wp-admin/post-new.php?post_type=assignment (working -- show_ui=true)
http://your-domain/wp-admin/edit.php?post_type=location (working)
http://your-domain/wp-admin/post-new.php?post_type=location (NOT working)
http://your-domain/wp-admin/edit.php?post_type=material (working)
http://your-domain/wp-admin/post-new.php?post_type=material (NOT working)

Note: this plugin creates four types of different custom post type location and material is two of them. Where show_ui is false. And show_ui is true for assignment custom post type which is working fine.

@lutond
9 years ago

Second upload - edited

#3 @lutond
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

#4 @TobiasBg
9 years ago

  • Milestone Awaiting Review deleted

#5 @SergeyBiryukov
9 years ago

  • Keywords reporter-feedback removed
  • Resolution changed from invalid to duplicate

Duplicate of #22214.

Note: See TracTickets for help on using tickets.