WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#31400 closed defect (bug) (duplicate)

image loses attributes when moved in editor

Reported by: shamai Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: accessibility Cc:

Description

If you add an image to the editor in wordpress and click it and press edit, you can add rel attributes and stuff.
If you link it and press edit you can add classes to the link and rel attributes for the link.

If you then move, via dragging the linked image around the editor, it seems to reset and you lose the rel attributes and classes you added for the link.
this is a bit annoying.

Change History (5)

#1 @iseulde
6 years ago

  • Version 4.1.1 deleted

#2 @tyxla
6 years ago

Actually, after dragging an image in the editor, the image loses its link. That is why it loses the rel and link class attributes - they are added to the link, so when the link is gone, they are also gone.

There is a ticket for the issue with image losing link on drag&drop - #28272, so this one could be closed as duplicate.

#3 @iseulde
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28272.

#4 @iseulde
6 years ago

  • Component changed from General to TinyMCE
  • Resolution changed from duplicate to fixed

#5 @iseulde
6 years ago

  • Resolution changed from fixed to duplicate

Duplicate of #28272.

Oops, not sure what happened.

Note: See TracTickets for help on using tickets.