WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#31421 closed defect (bug) (worksforme)

CSS files not loading in IE9 (Customize Component)

Reported by: saintron Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Customize Keywords: needs-testing
Focuses: ui, multisite Cc:
PR Number:

Description

We have a MU install of WordPress. While testing 4.1, we noticed what we think is a bug that only occurs in IE9. This issue has been replicated in 4.1 MU, 4.1.1 MU. It has also been replicated on a fresh, clean install of 4.1.1 on our localhost regardless of theme (2013, 2014 & 2015). The issue is with the Customize component and occurs when navigating to any of the following:
Appearance > Customize
Appearance > Customize > Background (if available)
Appearance > Customize > Header

The left sidebar renders fine. The right sidebar renders very small (see screen shot). The iframe tag does not have the height and width property set. We've done some testing and think the full CSS file isn't getting loaded. We think this is due to the known limitation of 4095 selectors in IE9. Upgrading to IE 10 is out of our control and we're hoping this issue can be replicated, documented and verified this issue doesn't occur in IE10.

Thanks.

Attachments (1)

Customizer Render Screen Cap 02232015.PNG (52.7 KB) - added by saintron 5 years ago.
IE9 Customize Screen Shot

Download all attachments as: .zip

Change History (6)

@saintron
5 years ago

IE9 Customize Screen Shot

#1 @SergeyBiryukov
5 years ago

#31437 was marked as a duplicate.

#2 @swissspidy
4 years ago

  • Keywords reporter-feedback close added

@saintron Is this bug still happening in the current version of WordPress, with all plugins disabled?

#3 @saintron
4 years ago

Our org upgraded to IE 11 soon after this issue was reported. After the upgrade, everything worked fine.

#4 @swissspidy
4 years ago

  • Keywords needs-testing added; reporter-feedback removed

#5 @SergeyBiryukov
4 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Haven't seen any other reports. If anyone has the same issue, feel free to reopen.

Note: See TracTickets for help on using tickets.