WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#31438 closed defect (bug) (duplicate)

Endpoints for front page return 404

Reported by: sccr410 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Rewrite Rules Keywords:
Focuses: Cc:
PR Number:

Description

When creating a new endpoint rewrite rule, assigning a page as the Front Page, the end points for the front page return a 404.

Example:

add_rewrite_endpoint( 'endpointname', EP_PERMALINK | EP_PAGES );

Create a page, call it Test which normally use a URL like www.domain.com/test

Make Test the Front Page.

If visiting a URL like: www.domain.com/endpointname/whatever - this returns a 404. This should load the home page with the endpoint rewrite rules in place.

If visiting www.domain.com/test/endpointname/whatever it works fine.

Change History (2)

#2 @swissspidy
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23867.

Note: See TracTickets for help on using tickets.