WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#31506 closed defect (bug) (duplicate)

Dashicons plus icon appears off-center

Reported by: AlexanderOMara Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Administration Keywords: ui-feedback 2nd-opinion has-patch needs-testing
Focuses: ui Cc:

Description

The WordPress Dashicon "plus" appears to be off-center in comparison to the other dashicons. For example, on the Dashicons page, we can see the icons is not quite vertically aligned with the other Notifications icons.

https://i.imgur.com/qCvRXOB.png

The horizontal centering is also off, as can be seen in this image I assembled.

https://i.imgur.com/dH1Y7l1.png

You can also see the difference on the GitHub repository, between plus and plus-alt. This makes the icon quite difficult to use.

Attachments (2)

35106.patch (218.3 KB) - added by eherman24 5 years ago.
My patch attemps to re-align the dashicon-plus svg image.
31506-2.patch (211.7 KB) - added by eherman24 5 years ago.
I re-laid out the plus.svg file using the appropriate 20px grid, and re-compiled the individual svg files into a singular font file.

Download all attachments as: .zip

Change History (8)

This ticket was mentioned in Slack in #design-dashicons by melchoyce. View the logs.


5 years ago

@eherman24
5 years ago

My patch attemps to re-align the dashicon-plus svg image.

@eherman24
5 years ago

I re-laid out the plus.svg file using the appropriate 20px grid, and re-compiled the individual svg files into a singular font file.

#2 @eherman24
5 years ago

  • Keywords ui-feedback 2nd-opinion has-patch needs-testing added

#3 @johnjamesjacoby
5 years ago

Nice work, Alexander & Evan.

I had noticed this also (but assumed there was some reason for it) so I can confirm I've had a similar experience with this icon.

#4 @melchoyce
5 years ago

I believe the + is off-center because it can't evenly fit within the circle — the only way would be to put the plus at half-pixel increments, which would make the icon appear fuzzy, especially at lower-resolution screens. @empireoflight, can you confirm?

This ticket was mentioned in Slack in #design-dashicons by melchoyce. View the logs.


5 years ago

#6 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.