WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#31555 closed defect (bug) (duplicate)

'Preview Changes' in CPT with non-standard Post Formats throws 404 error

Reported by: Faisal79c2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Post Formats Keywords:
Focuses: Cc:

Description

I've tested a few custom post type plugins (having post formats support).

ISSUE: While editing any CPT entry (having some post format assigned other than 'standard') if I want to view those changes and click on 'Preview Changes' button, it throws a 404 error.

The URL which throws 404 error is something like this ...

http://www.example.com/cpt-name/post-name/?preview_id=559&preview_nonce=0a0feaeab7&post_format=gallery

Now, if I remove

post_format=gallery

parameter from this URL, it works just fine and displays the post.

Change History (1)

#1 @DrewAPicture
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #31394.

Note: See TracTickets for help on using tickets.