WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#31567 closed defect (bug) (duplicate)

Categories not found in Multisite unless an user visits Permalink page

Reported by: rosyteddy Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Taxonomy Keywords:
Focuses: multisite Cc:

Description

WP 4.1.1 default installs
define( ‘WP_ALLOW_MULTISITE’, true );
define(‘MULTISITE’, true);
define(‘SUBDOMAIN_INSTALL’, false);
Registration Settings : Both sites and user accounts can be registered.
Using default Twenty-Fifteen theme
Testing in localhost and Apache server

Permalinks settings automatically changes without me having to do anything as shown in the picture
http://s16.postimg.org/v3unxnayd/prm3.png

To reproduce set up in localhost as above ( things should work in localhost too, isn't it?)

Now UserA signs up for both account and site.
When he visits the category “Uncategorized” –> Page not found
When he creates a post using say, Format: Gallery –> Clicking on ‘Gallery’ link under that post : Page not found
Now if he visits the UserA/wp-admin/options-permalink.php – just visits and does nothing, no saving, nothing – all the above errors vanish. “Uncategorized”, link “Gallery” everything works.
Same for user B , user C …
No idea if this is normal and expected or not.
I am searching how to do this automatically without the user having to compulsorily visit the Permalinks page. Mind you, the Permalink is already set to ‘Day and name’ – which is not “Default”, thus Permalink is already otherwise okay.

All other links including links like link to Monthly Archive works okay.

Change History (2)

#1 @DrewAPicture
5 years ago

  • Component changed from General to Taxonomy
  • Focuses multisite added
  • Keywords reporter-feedback added

Hi @rosyteddy, welcome to Trac!

Are you still experiencing this issue in 4.2 and/or the latest trunk?

#2 @boonebgorges
5 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the detailed report, rosyteddy.

It looks like your issue is a duplicate of #20171 (which I see you've already commented on!).

Note: See TracTickets for help on using tickets.