WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#31574 closed defect (bug) (worksforme)

the_content() displaying URL for embedded audio instead of player

Reported by: jkatcher Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Formatting Keywords: reporter-feedback close
Focuses: Cc:

Description

Hi all,

I have searched other tickets but wasn't able to successfully incorporate the responses - I'm also pretty new with wp so apologies and thanks so much in advance.

The issue is that when I'm retrieving content from my post in a loop, I'm able to pull the title and other attributes, but the player doesn't show up or when it does, it shows the code only. I can see it fine from the 'preview post', but when it's generated from the search, it doesn't show up.

Site - http://music.nicemanners.tv

Code from within individual post:

[audio mp3="http://music.nicemanners.tv/wp-content/uploads/2015/03/NM-7000.mp3"][/audio]

[za_show_download_button text="Download the file"]

Loop code:

<?php if ( $wpus_results->have_posts() ) : ?>
	
	<?php while ( $wpus_results->have_posts() ) : $wpus_results->the_post(); ?>

		<div class="post" id="post-<?php the_ID(); ?>">
			<br><?php the_title(); ?>
			<br><?the_tags(); ?>
			<br><?the_content(); ?>
		</div>
		
	<?php endwhile; ?>
	
	<?php if(wpus_option('clear_search')) { ?>
		<br><a id="wpus-clear-search" class="<?php echo wpus_option('clear_search_class') ?>" href="#"><?php echo wpus_option('clear_search_text'); ?></a>
	<?php } ?>
	
	<?php wp_reset_postdata(); ?>

<?php else : ?>

		<div class="wpus-no-results"><?php echo wpus_option('no_results_msg'); ?></div>

<?php endif; ?>

Attachments (2)

preview-page.png (27.2 KB) - added by jkatcher 5 years ago.
search-page.png (29.6 KB) - added by jkatcher 5 years ago.

Download all attachments as: .zip

Change History (4)

@jkatcher
5 years ago

@jkatcher
5 years ago

#1 @DrewAPicture
4 years ago

  • Component changed from General to Formatting
  • Keywords reporter-feedback close added

Hi @jkatcher, welcome to Trac. Sorry it took so long for somebody to respond.

Are you still experiencing these issues in 4.2 and/or the latest trunk? I was unable to reproduce your issue.

#2 @wonderboymusic
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Not reproducible since being marked close 5 months ago. Thanks for the ticket, though.

Note: See TracTickets for help on using tickets.