WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#31589 closed defect (bug) (duplicate)

Can't close Toolbar/Admin Bar Menu on small screens without activating menu item

Reported by: landwire Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Toolbar Keywords: reporter-feedback
Focuses: ui Cc:

Description

I am using the toolbar on the front end. When I tap to open the menu and then want to close it again without visiting a link, there is no way to close it, when the menu is very long and covers the whole screen. Even on the standard "Dashboard, Themes, Customise, etc." Menu that happens. When I click the icon again I get taken to the link attached to that icon.

As a solution it would be good to be able to just tap the icon again to close the menu, as is the behaviour of the "burger" of the toolbar in the admin area. Same problem goes for the profile link on the right. When there are lots of links in there, it also covers the screen and you cannot close it, as tapping the avatar again takes you to your profile.

Could that be enhanced? Or is there a patch already?
Thanks,
Sascha

Change History (4)

#1 @morganestes
5 years ago

  • Summary changed from Toolbar/Admin Bar Responsive Menu Problems on front end to Can't close Toolbar/Admin Bar Menu on small screens without activating menu item

#2 @morganestes
5 years ago

  • Keywords needs-patch added

#3 @morganestes
5 years ago

  • Keywords reporter-feedback added; needs-patch removed

Thanks for the report @landwire.

What devices and/or screen sizes are you having this problem? Can you take a screenshot or video of what you're seeing and share it here?

#4 @helen
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29906, fixed in 4.3.

Note: See TracTickets for help on using tickets.