WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#31659 closed enhancement (duplicate)

Multisite UX: "Add New" button on plugins page

Reported by: saracannon Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Networks and Sites Keywords:
Focuses: ui, multisite Cc:

Description

I propose the following simple UX improvement to WordPress Multisite: To include the "Add New" button on the plugins page within individual installs only when logged in as Network Admin. This will take you to wp-admin/network/plugin-install.php. Screenshot: http://s.sar.ac/image/3Q0k3S3x0K0J

It will be a UX improvement when managing plugins on a site within a multisite by taking away unnecessary hovers/clicks and (probable)confusion. Current action from a site plugin page is:

1) get confused why that button isn't there or why you have no prompts to install on the plugins page anywhere (probable).
2) in the admin bar: scroll over "my sites" then "network admin" then click plugins.
3) then finally hit that button that is in the same spot where you were in the first place but is there now that you are in the Network Admin section.

Caveat: I'm not sure if there is a UX standard already in place for MS. If it is believed as a general rule of thumb that going to the network admin section should be only through the admin bar, then I propose a different solution: to add "Install plugin" to that dropdown, also taking away a click. Screenshot: http://s.sar.ac/image/3r3y2q31211I

Change History (4)

#1 follow-up: @DrewAPicture
7 years ago

For reference, this was previously suggested and wontfixed in #24866.

#2 in reply to: ↑ 1 ; follow-up: @saracannon
7 years ago

Replying to DrewAPicture:

For reference, this was previously suggested and wontfixed in #24866.

I didn't see that - thanks!

What about my second suggestion about adding "Install Plugin" to the network admin dropdown a-la #21674 which also minimizes clicks/confusion? see screenshot: http://s.sar.ac/image/3r3y2q31211I

#3 in reply to: ↑ 2 @DrewAPicture
7 years ago

Replying to saracannon:

What about my second suggestion about adding "Install Plugin" to the network admin dropdown a-la #21674 which also minimizes clicks/confusion? see screenshot: http://s.sar.ac/image/3r3y2q31211I

Seems a little out of place to have something like that in the main Network Admin submenu. Plus we don't really have any other "action"-type links in the Toolbar anywhere outside of the "+ New" drop-down. I'd be -1 on the second suggestion, but remain +1 on the first.

#4 @DrewAPicture
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24866.

Note: See TracTickets for help on using tickets.