WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#31662 closed defect (bug) (duplicate)

Maybe the i18n textdomain module can be optimized?

Reported by: kmvan Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: I18N Keywords:
Focuses: performance Cc:
PR Number:

Description

http://i.imgur.com/KtP7BHz.png
I think the performance should be able to have a greater increase it.
I am not professional PHPer, but I can provide any test if I can do.:)

Change History (3)

#2 @greencp
5 years ago

You can use WP Performance Pack right now to vastly improve localization performance, either using a pure PHP MO reader or native gettext if available without any core patching.

#3 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the ticket kmvan.
To answer your question: Yes, it can/should be optimized. But general tickets like yours aren't much helpful, so I'm marking the ticket as a duplicate of the existing specific tickets, linked in comment:1.

Note: See TracTickets for help on using tickets.