WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#31745 closed defect (bug) (fixed)

Press This: inserted images link to the file and may be inserted in the blockquote

Reported by: azaozz Owned by: azaozz
Milestone: 4.2 Priority: normal
Severity: normal Version: 4.2
Component: Press This Keywords:
Focuses: Cc:

Description

The image links pointing to the files instead of the source site is caused by missing URL in the data passed to JS.

The inserting of images in the blockquote is caused by using mceInsertContent instead of editor.setContent() if the media is inserted before the editor is focused for the first time.

Change History (2)

#1 @azaozz
6 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 31868:

Press This:

  • Fix the links on inserted images to point to the source site.
  • Fix inserting of images above the blockquote when the editor has not been focused.

Fixes #31745.

#2 @stephdau
6 years ago

Nice. Thanks.

Note: See TracTickets for help on using tickets.