Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#31797 closed defect (bug) (invalid)

Dashicons not showing in Firefox or Chrome using html snippet

Reported by: mozdzanowski's profile mozdzanowski Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Administration Keywords:
Focuses: ui Cc:

Description

I'm using the html snippet provided on the Dashicons page. It's working fine in the latest version of Safari, but not in the latest versions of Chrome or Firefox. I don't think it could be a bug in my theme based on the fact that it works fine in Safari. Any ideas, or known issues with this?

Change History (7)

#1 @SergeyBiryukov
9 years ago

  • Summary changed from Dash icons not showing in Firefox or Chrome using html snippet to Dashicons not showing in Firefox or Chrome using html snippet

#2 @helen
9 years ago

  • Keywords reporter-feedback added

Not sure what you're referring to here?

#3 @mozdzanowski
9 years ago

When you go here, https://developer.wordpress.org/resource/dashicons/#cart, and click on Copy HTML, the snippet given is working just fine in Safari, but in Chrome and Firefox, the icon isn't showing. Seems to be a browser incompatibility in the core code used to deliver the icon called by the HTML snippet.

#4 @mozdzanowski
9 years ago

  • Keywords reporter-feedback removed

#5 @melchoyce
9 years ago

Have you enqueued Dashicons in your theme? (http://jespervanengelen.com/snippets/use-wordpress-dashicons-frontend/)

You're probably seeing them in Safari because you're logged in, so they're loaded for use in the admin bar, but anyone logged out wouldn't be seeing them loaded.

#6 @mozdzanowski
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Argh, my fault. Oversight, I'm afraid. Thanks for the help.

#7 @SergeyBiryukov
9 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.