WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#31810 closed defect (bug) (duplicate)

Installed Themes search: don't blur the search field when pressing Enter

Reported by: afercia Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Themes Keywords: has-patch
Focuses: ui, accessibility, javascript Cc:
PR Number:

Description

Pressing enter to execute a search is a common pattern. In WordPress all the other pages offer this behaviour. Instead, in themes.php the search field loses focus. Looks like this is intentional:

// Lose input focus when pressing enter
if ( event.which === 13 ) {
	this.$el.trigger( 'blur' );
}

This is confusing especially for keyboard users, not to mention screen reader users are totally lost. In fact, there's a focus loss and users will have to start tabbing again from the beginning of the page.

Would simply propose to remove it, don't see any reason for this feature, unless I'm missing something. See proposed patch.

Attachments (1)

31810.patch (471 bytes) - added by afercia 5 years ago.

Download all attachments as: .zip

Change History (3)

@afercia
5 years ago

#1 @afercia
5 years ago

  • Keywords has-patch added

#2 @joedolson
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26600.

Duplicate of 26600.

Note: See TracTickets for help on using tickets.