WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#31879 closed defect (bug) (duplicate)

Possible crash without any reporting in class-wp-image-editor-gd.php

Reported by: nevma Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Media Keywords:
Focuses: Cc:

Description

In certain situations, the processing of an image (e.g. via wp_generate_attachment_metadata()) can lead to unreported memory exhaustion in:

wp-includes/class-wp-image-editor-gd.php
line: 102
(public function load() )

At that point there is the statement:
$this->image = @imagecreatefromstring( file_get_contents( $this->file ) );

Since the errors are suppressed, the user is never notified of the issue, and the execution abruptly ends.

This is not a bug itself, but the issue should probably be communicated to the user somehow.

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Component changed from Post Thumbnails to Media
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23127.

Note: See TracTickets for help on using tickets.