Make WordPress Core

Opened 9 years ago

Closed 7 months ago

Last modified 6 months ago

#31907 closed defect (bug) (worksforme)

get_post_gallery()["src"] sometimes return empty on list views.

Reported by: odie2's profile odie2 Owned by: antpb's profile antpb
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Gallery Keywords: reporter-feedback
Focuses: Cc:

Description

Hello,

As wrote there: https://wordpress.org/support/topic/bug-get_post_gallery-on-7th-execution, sometimes get_post_gallery()["src"] is empty on list views (like post format view, main page pagination etc.)

Only ["src"] is not added to array (ids etc. are there), so it's returning false for if statement.

Greetings

Change History (5)

#1 @swissspidy
9 years ago

  • Keywords needs-patch added

#2 @antpb
7 years ago

  • Keywords reporter-feedback added; needs-patch removed

In the screenshot provided in the support issuehttps://wordpress.org/support/topic/bug-get_post_gallery-on-7th-execution/ (pictured below) this looks to be a problem with a plugin that modifies gallery view. The slider/pagination option does not seem to be available by default. Also mentioned in the support issue was that the example site was a modified version of twentyfourteen.

I've replicated gallery views in and unmodified twentyfourteen instance with 11 posts. All showed to be uniform on the main page (with pagination)

@odie2 can you confirm that this is still an issue? Maybe I'm missing something.

Below is the provided example from the support issue:

http://maciej.kuzniczysko.pl/images/zs-bug.jpg

#3 @antpb
7 years ago

  • Owner set to antpb
  • Status changed from new to accepted

#4 @rodrigosprimo
7 months ago

  • Resolution set to worksforme
  • Status changed from accepted to closed

Closing as there has been no feedback in a few years, and Anthony was not able to reproduce the problem. Feel free to reopen with more information if there's still an issue.

#5 @swissspidy
6 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.