WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#31931 closed defect (bug) (duplicate)

Editor: Quotation marks don't always close correctly

Reported by: siobhyb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Formatting Keywords: needs-patch
Focuses: Cc:

Description

Quotation marks don't close correctly in the editor in cases where both of the following are true:

  • The words in between the quotation marks are formatted e.g. they're bold, underlined, or italicised.
  • The quotation marks are the last ones on the post/page.

This is especially noticeable in languages such as French, where angled quotes are used for quotation marks. Additionally, this isn't reproducible in cases where the quotation marks themselves have been included in the formatting, just when the words in between them have.

Examples:




HTML content to test with:
https://cloudup.com/c6vhZ2dYTOG

We were able to reproduce this on WP.com (WP 4.2 alpha, using several different themes, and in French and English language) and then on a WP.org install (latest trunk, using Twenty Fifteen theme and English language).

Attachments (5)

english-quotes.png (48.5 KB) - added by siobhyb 4 years ago.
quotation1.png (48.4 KB) - added by siobhyb 4 years ago.
quotation2.png (65.1 KB) - added by siobhyb 4 years ago.
31931.patch (1.1 KB) - added by iseulde 4 years ago.
31931.2.patch (1.3 KB) - added by iseulde 4 years ago.

Download all attachments as: .zip

Change History (11)

@siobhyb
4 years ago

@siobhyb
4 years ago

#1 @siobhyb
4 years ago

  • Summary changed from Editor: Formatted quotation marks don't always close correctly to Editor: Quotation marks don't always close correctly

#2 @iseulde
4 years ago

  • Component changed from Editor to Formatting

#3 @iseulde
4 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release
  • Version trunk deleted

Happens in 4.1 too. Confirmed the problem for the last paragraph in the example.

#4 @lancewillett
4 years ago

I'm able to repeat, also, using the same test content — in trunk ((4.2-beta4-32057-src) with Twenty Fifteen theme.

@iseulde
4 years ago

@iseulde
4 years ago

#5 @miqrogroove
4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18549.

#6 @DrewAPicture
4 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.